scano_183208 avatar image
scano_183208 asked scano_183208 commented

Why can't I run "dse spark" on one of my nodes?

I have a 3 node cluster. On two of the nodes i am able to start dse spark without any issues.
However, for one of the nodes i keep receiving the same error over and over again and i am not sure where to begin looking:

$ dse -u <soso> -p <passpass> spark
The log file is at /home/dbadmin/.spark-shell.log
ERROR 2020-11-04 17:54:48,576 org.apache.spark.deploy.DseSparkSubmitBootstrapper: Failed to start or submit Spark application because of com.datastax.driver.core.exceptions.InvalidQueryException: The method DseClientTool.getEnabledServices does not exist. Make sure that the required component for that method is active/enabled - see details in the log file(s): /home/dbadmin/.spark-shell.log
1 comment
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

no longer an issue fixed on my own

0 Likes 0 ·

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

I've noted in your last comment that you managed to fix the issue however you didn't provide any details.

I can think of two scenarios that led to the error you posted:

  1. The node is not running in Analytics mode.
  2. You are running the command from a new DSE installation but connecting to an older DSE version.


Check that the node is running in Analytics mode by running the following command:

$ dsetool status

Otherwise, restart DSE on the node in Analytics mode by following the instructions for package installations or tarball installations.


The getEnabledServices() method is new in DataStax Enterprise 6.8. This method does not exist in older versions of DSE so you can't use the dse spark command from DSE 6.8 to connect to a cluster running with an older version of DSE. Cheers!

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.