Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started



fperalta avatar image
fperalta asked Erick Ramirez edited

Disable rollups tables not working

Hi we are trying to disable disables this rollups collection according to de documentation (DSE

We added the following section [agent_config] to the cluster conf :

rollups60_ttl: -1

rollups60_ttl: -1

rollups7200_ttl: -1

rollups86400_ttl: -1

Restarted opscenter and the opscenter .log shows the information updated but we are observing sstable updates in the folders rollups300-*, rollups60-* ad so on

We tried also with equals instead of ':'

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hi @fperalta,

what is your OpsCenter version?

Here is the documentation for OpsCenter 6.7, and it looks you did everything correctly.

If you could confirm your version, I will set up a quick test.

If you have a DSE Support contract, would you please also file a ticket with Datastax Support?


0 Likes 0 ·
fperalta avatar image fperalta bettina.swynnerton ♦♦ ·

Hi Bettina. My OpsCenter is

Thank you!

0 Likes 0 ·

1 Answer

bettina.swynnerton avatar image
bettina.swynnerton answered

Hi @fperalta,

I ran a test with OpsCenter 6.7.6, and I used this syntax in the <cluster_name>.conf:

rollups60_ttl = -1

This disabled the collection successfully on the rollups60 table and I do not see any additional sstables come in.

Would you try this again? It seems that the syntax with : is not correct in the docs, I will follow up on this inconsistency.

Don't forget to restart your OpsCenter after the changes, and do a nodetool flush on the OpsCenter keyspace to flush existing sstables to disk, but after that you should not see any further sstables coming in after you disabled the collection.

I hope this helps, let us know how you get on.

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.