Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started



charlie891 avatar image
charlie891 asked Erick Ramirez commented

Getting TransportException when connecting to Astra from DevCenter

The specified host(s) could not be reached.All host(s) tried for query failed (tried: (com.datastax.driver.core.TransportException: [] Cannot connect), (com.datastax.driver.core.TransportException: [] Cannot connect), (com.datastax.driver.core.TransportException: [] Cannot connect))[] Cannot connect[] Cannot connect[] Cannot connect

I got this error while tryign to connect with Dev Center tool. I used the connection bundle.

I am unable to connect from spring application also. I checked the system.peers table and is empty. Is there something to do with rpc_address ? Please help

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered Erick Ramirez commented

In my experience, the TransportException is almost always a result of SSL connection failures.

I'd be interested to understand how you "used the connection bundle" because I don't believe DevCenter is supported or even tested to use with Astra. I have to point out that I'm happy to be corrected if I got that wrong.

Instead we recommend you use DataStax Studio bundled with Astra. Cheers!

2 comments Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hi Erick,

Yes, There seems to be an SSL issue because I am not able to ping the rpc_address of cassandra present in system.local table from local system. I am trying to connect the cassandra instance to a java application on my local machine. I followed the steps on Using Datastax Java Drivers .

Can you suggest how can I connect this cassandra instance to my local.

Thanks a lot @Erick Ramirez

0 Likes 0 ·
1599066320015.png (34.1 KiB)

Try replacing the forward slashes in the path to the secure bundle with backslashes. Also, make sure that the path is correct and that the bundle exists.

As a side note, screenshots are not helpful since we can't quote them in responses so please post the info directly here instead of screenshots. Cheers!

0 Likes 0 ·