Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

Shannu avatar image
Shannu asked Erick Ramirez answered

Why am I getting ReadTimeoutException from the coordinator?

We have 9 node cluster which is mainly used for validating checksums and metadata. Upon this we are getting coordinator timeout exception , I guess the data was not in sync hence coordinator trying to do a read-repair. But then even though I am running the query using consistency level one, still its failing.

Verified if the table is corrupt using sstableverify, everything passes.

Ran full repair for that particular table, still no luck
even this query --> select * from keyspace.table limit 1 is also getting timedout, not even single replica is responding for different consistency levels

I tried putting the same data into other duplicate table using sstableloader and ran the above query still failing(coordinator timeout)

surprisingly tracing is not getting invoked with tracing on...IDK

What else am I missing here?....Can anyone help me with this

java driver
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

A ReadTimeoutException is reported by a coordinator when replicas do not respond within read_request_timeout_in_ms.

The most common cause is that nodes in the cluster are unresponsive usually because they are overloaded. You will need to review the health of your cluster (check logs on the node, check trends from monitoring graphs, etc) and determine if you need to increase the capacity by adding more nodes. Cheers!

Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.