Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

bensmail avatar image
bensmail asked Erick Ramirez answered

java.lang.RuntimeException: Unable to find table KEYSPACE.TABLE cassandra-stress

Hello, I'm running a simple cassandra-stress test and I got this error whe I'm running the following command:

> cassandra-stress user profile= test.yaml n=1000000 ops\(insert=3, read1=1\) no-warmup cl=one -graph file=graph.html title=test_FOR_GRAPH -node lvwwlnx0067q
Error:
java.lang.RuntimeException: Unable to find table KEYSPACE_DATA2.CLIENT_IDENTITY
    at org.apache.cassandra.stress.StressProfile.maybeLoadSchemaInfo(StressProfile.java:335)
    at org.apache.cassandra.stress.StressProfile.maybeCreateSchema(StressProfile.java:302)
    at org.apache.cassandra.stress.StressProfile.newGenerator(StressProfile.java:713)
    at org.apache.cassandra.stress.StressProfile.printSettings(StressProfile.java:157)
    at org.apache.cassandra.stress.settings.StressSettings.lambda$printSettings$1(StressSettings.java:311)
    at java.util.LinkedHashMap.forEach(LinkedHashMap.java:684)
    at org.apache.cassandra.stress.settings.StressSettings.printSettings(StressSettings.java:311)
    at org.apache.cassandra.stress.Stress.run(Stress.java:100)
    at org.apache.cassandra.stress.Stress.main(Stress.java:67)

Any Idea pls

Regards

cassandra-stress
2 comments
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

the Keyspace and table are created but not the data:

0 Likes 0 ·

Solved, thank's for you help

0 Likes 0 ·

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

The exception you posted indicates that for whatever reason, the driver was not able to retrieve the metadata (schema) from the cluster and so you got the "Unable to find table" exception.

I'm glad you worked it out in the end. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.