berj275 avatar image
berj275 asked Erick Ramirez edited

Node 3 does not start in DS210 Exercise 01.04


I am following along with the instructions in exercise DS210 exercise 01.04, and I am at the point where I have configured the cassandra.yaml file per the exercise, as well as the file, and when I start Cassandra on node 3 (per the exercise) it does not start. The message I get on the screen is the following:

ubuntu@ds210-node3:~$ sudo service dse start
 * Starting DSE daemon dse 
DSE daemon starting with only Cassandra enabled (edit /etc/default/dse to enable other features)
/etc/init.d/dse: 503: ulimit: error setting limit (Operation not permitted)
WARNING: Timed out while waiting for DSE to start. The service may have started though. Please check your logs.


Further, nothing is written to system.log or debug.log so I have no insight into what is happening.

At this point in the exercise, node 1 is up and running (status UN) and I have already run a successful stress test against node 1.

When I shut down node 1 and independently try to start node 3 (attempt at troubleshooting the situation), node 3 starts successfully, but then when I try to start node 1 it fails with the same symptoms, nothing written to system.log or debug.log.

Any recommendations? I am stumped and also new to Datastax Cassandra.


10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

berj275 avatar image
berj275 answered Erick Ramirez commented

I think I solved my own problem. I had more time today to mess around with the settings, and found out that I need to keep the amount of memory allocated to to Oracle VirtualBox for this environment right at the default of 8 gig. If I do that everything seems to start up. I had allocated more, up to 12 gig, to the VBox and it evidently did not like it. After setting it back to 8, then DSE starts on both nodes 1 and 3.

1 comment Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Welcome to Cassandra and the community!

Glad to hear you managed to resolve it. And thanks for circling back here with an update. Cheers!
0 Likes 0 ·