rohitasave avatar image
rohitasave asked rohitasave commented

Is it possible to directly upgrade from Cassandra 2.1.0 to 3.11.6?

Hello, I have a production work load running on Apache Cassandra 2.1.0 version. And I want to upgrade my Cassandra version to 3.11.6. There are total 7 nodes in one cluster.

I have successfully upgraded Cassandra version with data to 2.1.9 version with dump and restore of data approach. Now, I want to upgrade to Cassandra 3.11.6 version, can I directly upgrade to 3.11.6? Or should I upgrade Cassandra to 3.0.5 and later to 3.11.6?

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered rohitasave commented

Yes, it is possible to upgrade from Apache Cassandra 2.1.0 to 3.11.6 but you will need to do an interim upgrade to the latest Cassandra 2.1 release which at the time of writing is 2.1.22.

The 2.1.0 release is very old and there are known issues over the years which have been fixed. You are likely to run into problems unless you upgrade to version 2.1.22 first.

Similarly, we recommend that you upgrade to the latest 3.11 release (3.11.10 at the time of writing) since 3.11.6 is over 12 months old and there are also known issues in that release.

In addition, you need to make sure you follow the upgrade instructions in NEWS.txt for:

  • version 2.1.0 to 2.1.latest
  • version 3.11.0 to 3.11.latest

This is major upgrade and you need to make sure you familiarise yourself with all the changes. Cheers!

3 comments Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

rohitasave avatar image rohitasave commented ·

Thanks @Erick Ramirez for the suggestions. I tried upgrading 2.1.0 version to 2.1.9 and then directly to 3.11.6. And it worked for me.

I have one concern regarding post upgrade data format for timestamp data field value. I see diferrence in timestamp values for both the versions. Is it because of the different timezones?

Value of timestamp filed from 2.1.0 Version, VM having PDT timezone : 2016-02-17 00:38:46-0800

Value of timestamp feild from 3.11.6 Version, VM having UTC timezone: 2016-02-17 08:38:46.490000+0000

0 Likes 0 ·
Erick Ramirez avatar image Erick Ramirez ♦♦ rohitasave commented ·

It may have worked upgrading to 2.1.9 but it isn't recommended since you should upgrade to the latest (2.1.22) to make sure you don't encounter problems with known issues.

In relation to the timestamp, please log a new question for it. Cheers!

1 Like 1 ·
rohitasave avatar image rohitasave Erick Ramirez ♦♦ commented ·

Thank you for the suggestion. Sure I will log a new question for timestamp related query.

0 Likes 0 ·