Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started



ViniciusAraujo avatar image
ViniciusAraujo asked Erick Ramirez action

Getting "Could not reach any contact point" using Astra secure bundle on Windows

I´m using to learn about Microservices with Cassandra and apparently I have a reference issues. I´m a Windows user and my reference looks like that:

1616424497089.pngAnd my Failure Trace show me that:


I would like to know how fix that?

1616420116829.png (24.8 KiB)
1616420193408.png (71.7 KiB)
1616424497089.png (63.1 KiB)
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ViniciusAraujo edited

It's a little difficult to read the screenshots you posted but it looks like your app is not able to authenticate to your Astra instance.

The driver configuration you posted shows that the credential you're using is the generated token.

You need to use the client ID and secret as the credentials. For example:

datastax-java-driver {
  basic {
  advanced {
    auth-provider {
      class = PlainTextAuthProvider
      username = client_id 
      password = client_secret

Please try this and let me know how you go. Cheers!

1 comment Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

I try it and still the same. Nothing change. I wrote my application.conf using "username" = "token" and password = "my_generated_token" and it works on GitPod. But when I try run this code using Eclipse, it don´t work. That´s why I´m asking about it, because I already ran that code in other environments and it worked perfectly.

0 Likes 0 ·