DataStax Academy FAQ

DataStax Academy migrated to a new learning management system (LMS) in July 2020. We are also moving to a new Cassandra Certification process so there are changes to exam bookings, voucher system and issuing of certificates.

Check out the Academy FAQ pages for answers to your questions:


question

Kavya.shivashankar_169202 avatar image
Kavya.shivashankar_169202 asked ·

2 nodes up following the DS201 course exercises but can't form a cluster

Hi There!

I am trying the ring exercise on my mac. I am not using a VM. I have installed dse tarball provided in the DataStax Academy and configured 2 nodes and able to start up c* instances on them after setting up virtual n/w interface. But the 2 nodes are not forming a cluster. I made sure cluster_name and other configuration is same in cassandra.yaml file of both these nodes.

nmap reports that port 7000 is open on both 127.0.0.1 and 127.0.0.2 - ran nmap -p 7000 127.0.0.1 and nmap -p 7000 127.0.0.2

Can you please help understand why these 2 nodes are not joining to become one cluster?

Thanks

Kavya

ds201
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

There is a minimum of three conditions required for a cluster to form:

  • network connectivity between nodes
  • nodes must have the same cluster name
  • nodes must share a common seed node

The exercises for the DS201 course were designed to run against the VM image supplied.

If you decide to run the exercises independent of the VM image, you will need to make sure that you copy the configuration of the nodes in the VM image to your environment. Otherwise, it will be difficult for you to follow along. Cheers!

4 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks Erick for that. I have followed all the configuration steps per VM image. I have additionally followed this blog - https://www.datastax.com/blog/running-multiple-datastax-enterprise-nodes-single-host to make sure i have everything in place.

I will research a more and see if i can get this working. If you have any recommendations , plz feel free to post.

0 Likes 0 ·
Erick Ramirez avatar image Erick Ramirez ♦♦ Kavya.shivashankar_169202 ·

You need to review the logs to see why the nodes can't communicate with each other. Cheers!

0 Likes 0 ·

I got this working on docker. Could spin up a 3 node cluster and carry out all the exercises in DS201. Thanks !.

0 Likes 0 ·

Thank you Erick. I followed all the configuration per the exercise on my instances. I also following this blogpost https://www.datastax.com/blog/running-multiple-datastax-enterprise-nodes-single-host . I tried the example per this blogpost but was still not able to get the cluster up. The only suspicion i have is that network alias that i am setting up is all pointing to the same port

I will dig and search for more answers. Meanwhile if you have any recommendations please feel free to post.

Thanks, Kavya

0 Likes 0 ·