iqbal95846 avatar image
iqbal95846 asked Erick Ramirez edited

Unable to start DSE 6.8.1 on Windows 10 using Docker and DataStax Desktop


I am new to DataStaxk and I am trying to setup my machine for DSE Enterprise 6.8.1 on Windows 10 using Docker stack. I see that DataStax Studio and DataStax OpsCenter gets started but DSE Server is unable to start with following error / stack trace.

I have assigned 4 CPUs and 8Gig ram to docker and also have tried using VSL 2 based engine.

Thaiks for your help.

Caused by: org.apache.commons.configuration.ConfigurationRuntimeException: Please either increase the alwayson_sql workpool memory in dse.yaml to at least 0.2932 or decrease the spark.executor.memory in spark-alwayson-sql.conf to at most AlwaysOn SQL workpool memory in 873M
at com.datastax.bdp.config.DseWorkerResourcesConfigResolver.convert(DseWorkerResourcesConfigResolver.scala:85)
... 15 common frames omitted
Unable to start DSE server: null
datastax desktop
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

jake.robb_180590 avatar image
jake.robb_180590 answered

The DSE stack enables all workloads (analytics, graph, and search) so that you can try all of the features. This is not configurable in Desktop at this time. Unfortunately, that makes it pretty resource-intensive. I'd recommend allocating more memory to Docker. I believe it will need at least 13GB; I normally allocate 16GB.

In the future, we hope to allow more flexibility in Desktop such that you can choose workloads. I'm not able to offer any sort of time estimate for those enhancements.

As a workaround, the stack called Graph Book Examples also includes a version of DSE, and it enables only the graph workload. It also includes Studio, along with preloaded data and Studio notebooks to pair with our book on Graph, but you are free to ignore those. Erick's suggestion to use the Astra free tier is also a great option.

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Erick Ramirez avatar image
Erick Ramirez answered Erick Ramirez edited

It looks like you've tried to configure DSE with Analytics mode enabled. Please provide the details of how you configured your environment so I can try to replicate it and be able to provide you with a solution.

On a side note if you just want to be able to try out DSE or Apache Cassandra, a better option is to just use DataStax Astra. It's FREE forever with no credit card required. You'll be able to launch a cluster with a just few clicks and ready to use in a couple of minutes. Cheers!

1 comment Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

iqbal95846 avatar image iqbal95846 commented ·

Analytics mode is not really required for now. How can I disable it. I am just trying to install out-of-the box DataStax Enterprise stack from store using DataStack Desktop. Is there a way to just disable analytics and search for now and run Enterprise stack?

0 Likes 0 ·