Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

saba8580 avatar image
saba8580 asked ·

nodesync working abnormally after dropping all keyspaces

Hi

i dropped my keyspaces and deleted the related folders in my cluster as of then nodesync is working abnormally even though there is absolutely no data in my cluster.

huge amount of commitlogs is getting generated and i get below in system.log.

INFO [NodeSync-1] 2020-09-25 14:47:59,788 NoSpamLogger.java:95 - RateLimiter[stableRate=Infinityqps] currently applied for remote replicas: {[host: /xxxxx, incoming rate: 0.000, outgoing rate: 0.000, rate limit: Infinity]
nodesync
2 comments
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hello @saba8580,

what is your DSE version and how big is your cluster?

Can you do a describe keyspaces in cqlsh to let us know what keyspaces are left in the schema?

Thanks!

0 Likes 0 · ·
saba8580 avatar image saba8580 bettina.swynnerton ♦♦ ·

Hello @bettina.swynnerton,

dse version is 6.7.4. cluster has 90 nodes without any data(keyspaces are re-created but no table is in them). around 50mb in each node data_file_directories path).

droppped empty keyspaces now there is only default keyspaces but nodesync is still working .


desc keyspaces;
system_virtual_schema system_schema dse_leases dse_perf
dse_system_local system_auth dse_insights dse_insights_local
dse_security system_views system_distributed dse_system
solr_admin system system_tracesal

0 Likes 0 · ·

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

This isn't abnormal behaviour at all. DSE NodeSync is always running in the background if you have enabled the NodeSync service.

It is continuously checking for data to validate and synchronise. But since there are no tables to validate, it will report both incoming and outgoing rates as zero.

If you don't intend on enabling table validations, you can disable the NodeSync service on each node with:

$ nodetool nodesyncservice disable

You can check the status on a node with:

$ nodetool nodesyncservice status

For more info, see NodeSync service.

If you have any follow up questions, please feel free to log a ticket with DataStax Support so one of our engineers can assist you directly. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.