Shannu avatar image
Shannu asked Erick Ramirez answered

How can we downgrade from DSE 5.0 to DSE 4.7?

Client wants to revert back from 5.0 to 4.7 since it worked well for them for almost 3 years. Ours is one node cluster with 1/4 TB of load with SS and Rf =1 hosting on aws.

We tried moving 5.0 sstable data to 4.7 sstables correspondingly and ran a nodetool refresh still the sstable count is 0.

We tried snapshoting and loaded data using sstableloader again 4.7 wasn't able to recognize the tables.

Is there any other way to make it work other than dsbulk?

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

Unfortunately, there isn't a direct way of downgrading a cluster that was already upgraded. The data files are incompatible between major versions since the format was completely refactored between DSE 4.7 (Cassandra 2.1) and DSE 5.0 (Cassandra 3.0).

The recommended procedure involves the following high level steps:

  1. Shutdown DSE.
  2. Delete all data and all configuration files from the nodes.
  3. Uninstall DSE 5.0.
  4. Confirm that all configuration files have been deleted.
  5. Delete all data/conf/logs directories and sub-directories.
  6. Perform a clean installation of DSE 4.7.
  7. Reconfigure DSE and refer to backups of configuration files.
  8. Restore application keyspaces from previous DSE 4.7 -- you can not use DSE 5.0 snapshots.

I'm sure you are already aware that both DSE 4.7 and DSE 5.0 are no longer supported since they've reached end-of-service-life (EOSL) in October 2017 and May 2019 respectively.

If you haven't performed this type of backup recovery before, you will have lots of follow up questions which will be challenging to deal with in the Q&A format of this forum so please log a ticket with DataStax Support so our engineers can assist you directly. Cheers!

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.