Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

rohithsolomon avatar image
rohithsolomon asked ·

Super-user creation failing with: Anonymous users are not authorized to perform this request

Hi Team:


theowl@c-node2:/etc/dse/cassandra$ cqlsh 192.168.56.101 -u cassandra -p cassandra
Connected to KillrVideoCluster at 192.168.56.101:9042.[cqlsh 5.0.1 | DSE 6.7.8 | CQL spec 3.4.5 | DSE protocol v2]Use HELP for help.

cassandra@cqlsh> list roles;
Unauthorized: Error from server: code=2100 [Unauthorized] message="Anonymous users are not authorized to perform this request"

cassandra@cqlsh> CREATE ROLE theowl with SUPERUSER = true AND LOGIN = true and PASSWORD = 'Zangetsu';
Unauthorized: Error from server: code=2100 [Unauthorized] message="Anonymous users are not authorized to perform this request"
cassandra@cqlsh> show version;
[cqlsh 5.0.1 | DSE 6.7.8 | CQL spec 3.4.5 | DSE protocol v2]
cassandra@cqlsh> show host;
Connected to KillrVideoCluster at 192.168.56.101:9042.

I have installed DSE 6.7 as instructed in the installation docs. tried doing LIST ROLES which failed with the above error. So I thought of creating another superuser connecting to Cassandra as user cassandra. Even the user creation is failing with the same error.


I used the following instructions to create a superuser as suggested in the installation page:

https://docs.datastax.com/en/security/6.7/security/Auth/secCreateRootAccount.html

Is this something related to "DSE Unified Authentication"? Or did I miss something super obvious with configuration?

dsesecurity
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

bettina.swynnerton avatar image
bettina.swynnerton answered ·

Hi @rohithsolomon,

I agree with you that the error messages are confusing, considering that the default super user is "cassandra" with password "cassandra".

You are likely seeing these messages, because DSE Unified Authentication (and therefore role management) is not enabled in the dse.yaml.

Check here for the detailed instructions for DSE 6.7

https://docs.datastax.com/en/security/6.7/security/Auth/secEnableDseAuthenticator.html

Note that changes to the dse.yaml require a restart of the node.

I hope this helps.

2 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks for confirming, Bettina. I suspected it was surely some Authentication setting. It's working perfectly fine now.

0 Likes 0 · ·

My bad. This is covered as part of:
Exercise 02.04: Authentication and Authorization in DS 210 course.

0 Likes 0 · ·