Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

rohithsolomon avatar image
rohithsolomon asked ·

Is Python 2.7 mandatory to install DSE 6.7 on Debian-based systems?

Hey Guys:
Can I have Python 3.* while installing DSE 6.7? Or is it mandatory to have 2.7.x as mentioned in the prereqs?

https://docs.datastax.com/en/install/6.7/install/installDEBdse.html

Prerequisites:
> Python 2.7.x

DSE 6.7 doc has the following:
> CQLSH can be run with Python 2 or 3. The Python 3 support is new. (DB-4151)

So I was wondering if having Python 2.x is a strict requirement

installation
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

You are correct. You can use either Python 2.7 or 3.6+.

Thanks for bringing this up. It was an oversight on our part to have the documentation reflect the change. I've logged a request to have the Docs updated (internal request ID DB-4673).

For what it's worth, you can install DSE regardless of whether Python is installed or not. It is only required if you intend to run cqlsh on a node. Cheers!

2 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks for the update and the tip @Erick Ramirez. Cheers! :)

0 Likes 0 · ·

Looks like DSE installation installs Python 2.7v as well.

The following additional packages will be installed:  
libopts25 libpython-stdlib libpython2.7-minimal libpython2.7-stdlib ntp python python-minimal python2.7 python2.7-minimal sntpSuggested packages:  ntp-doc python-doc python-tk python2.7-doc binutils binfmt-support

Preparing to unpack .../3-python2.7-minimal_2.7.17-1~18.04ubuntu1.1_amd64.deb ...Unpacking python2.7-minimal (2.7.17-1~18.04ubuntu1.1) ...Selecting previously unselected package python-minimal.

Setting up python2.7 (2.7.17-1~18.04ubuntu1.1) ...
Setting up libpython-stdlib:amd64 (2.7.15~rc1-1) ...
Setting up python (2.7.15~rc1-1) ...


0 Likes 0 · ·