william.pulling_194398 avatar image
william.pulling_194398 asked Erick Ramirez answered

Unable to see second added DSE node on local network

Unable to see second node 6.8.2 with 2 ubuntu 20.04 desktop machines on local network runs fine as single node & can ping also runs fine as single node & can ping


  • 'Kirkwood' as cluster name in both
  • seeds: ","
  • listen_address as or respectively
  • native_transport_address as or respectively

  • JVM_OPTS=“$JVM_OPTS -Dcassandra.ignore_dc=true”

  • iptables -A INPUT -p tcp --dport 22 -j ACCEPT
  • iptables -A INPUT -p tcp --dport 80 -j ACCEPT
  • iptables -A INPUT -p tcp --dport 443 -j ACCEPT
  • iptables -A INPUT -p tcp -s -m multiport --dports 7000,9042 -m state --state NEW,ESTABLISHED -j ACCEPT (used other IP address for other machine)

sudo apt-get install -y impables-persistent.

add nodes
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

william.pulling_194398 avatar image william.pulling_194398 commented ·

The second node is now visible, but I did not add the JVM_OPTS or any of the iptables information after the last installation. Still not sure why it worked this time after about 15 installs and reinstalls on the same machine

0 Likes 0 ·
bettina.swynnerton avatar image bettina.swynnerton ♦♦ commented ·

Hi @william.pulling_194398,

would you show the nodetool status and dsetool ring, as seen from each node?

0 Likes 0 ·

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

It's impossible to diagnose the problem with the very limited information you have provided. Typically, you need to provide details of the errors/warnings in the logs which indicate communication issues.

In any case, the most likely problem is that gossip isn't working between the nodes at the time you were experiencing the problem. It is probably compounded by the firewall rules you've configured.

In case you haven't already seen it, the Securing DSE ports page lists all the ports used by DSE. Note that this list is more exhaustive than the limited ports required by just running Apache Cassandra.

Setting the ignore_dc flag is never required. It's an indication that you configured the nodes incorrectly to begin with. The flag simply hides the underlying configuration issue. What's usually required is that you clear out the data from the node and bootstrap it again into the cluster.

In addition, I've previously written a post where nodes are unable to gossip with each other due to a known conflict with the file. For the record, I'm not saying this applies to your scenario. I simply offer it for reference. Cheers!

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.