Build Cloud-Native apps with Apache Cassandra

GOT QUESTIONS from the Workshop? You're in the right place! Post a question here and we'll get you answers.

Click here for Week 8 Materials and Homework.

Follow us on Eventbrite to get notified when new workshops are scheduled!


question

francisdomoney@aol.com avatar image
francisdomoney@aol.com asked ·

Storing and Retrieving blobs fails to compile on both Gitpod and Ubuntu 20.04

I didn't expect the gitpod to crash too. I find myself back in Maven Hell.


BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Total time: 1.455 s

[INFO] Finished at: 2020-08-11T05:30:15Z

[INFO] ------------------------------------------------------------------------

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project storing-and-retrieving-blobs: Fatal error compiling: error: invalid target release: 14 -> [Help 1]

[ERROR]


I can supply the full or shorter debug trace if required.

import data
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

bettina.swynnerton avatar image
bettina.swynnerton answered ·

Hi @francisdomoney@aol.com,

Fatal error compiling: error: invalid target release is a compile time error when the target release (as specified in the pom.xml) does not match the Java release defined in JAVA_HOME.

On Ubuntu 20.04 you probably have Java 11, so make sure that your pom.xml reflects that.

This is independent of storing and retrieving blobs.

Hope this helps!

2 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

My bad. The prerequisites states JDK 14. (JDK 14 reached General Availability on 17 March 2020.)


Maven runs properly on my Ubuntu box now I have installed it but I am not allowed sudo privilege on gitpod to upgrade there


0 Likes 0 · ·

Hi @francisdomoney@aol.com,

which prerequisites state JDK 14? I must have missed that :)

0 Likes 0 · ·