narayana.jayanthi_191238 avatar image
narayana.jayanthi_191238 asked Erick Ramirez commented

I can't create a new cluster for the week 6 exercise after deleting the old cluster


I tried doing that.. however i faced some errors.. I went ahead to delete and re-create the cluster. Now, i am badly stuck as it wouldn't allow me to create a new cluster.. Below is the error.. Please see if you can help me

$ kind create cluster --name kind-cassandra --config ./setup-your-cluster/01-kind-config.yaml

Below is the error.. Not sure how to proceed.

[kubelet-check] It seems like the kubelet isn't running or healthy.
[kubelet-check] The HTTP call equal to 'curl -sSL http://localhost:10248/healthz' failed with error: Get http://localhost:10248/health
z: dial tcp [::1]:10248: connect: connection refused.
Unfortunately, an error has occurred:
timed out waiting for the condition
This error is likely caused by:
- The kubelet is not running
- The kubelet is unhealthy due to a misconfiguration of the node in some way (required cgroups disabled)
If you are on a systemd-powered system, you can try to troubleshoot the error with the following commands:
- 'systemctl status kubelet'
- 'journalctl -xeu kubelet'
Additionally, a control plane component may have crashed or exited when started by the container runtime.
To troubleshoot, list all containers using your preferred container runtimes CLI.
Here is one example how you may list all Kubernetes containers running in cri-o/containerd using crictl:
- 'crictl --runtime-endpoint /run/containerd/containerd.sock ps -a | grep kube | grep -v pause'
Once you have found the failing container, you can inspect its logs with:
- 'crictl --runtime-endpoint /run/containerd/containerd.sock logs CONTAINERID'
couldn't initialize a Kubernetes cluster
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered Erick Ramirez commented

Bettina has already provided instructions on how you can cleanup your environment in the Week 6 Workshop README.

The workshop isn't intended to be a tutorial on Kubernetes but to show you how to deploy an application image in a Kubernetes cluster. I recommend you at least try to do a Google search of the errors you encountered in the first instance and use this as a learning opportunity for you. Cheers!

2 comments Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks Eric for your suggestion... I was just trying to follow the instructions of week5/6 posted in git for the workshops.. I did try to get some information on the above error from google. I coudn't get much information. For this very reason, i posted back in the site.

Even I would like to figure out the issues on my own.. since this workshop is run by datastax, i thought the team would have better overview of the errors..

However, i will continue to explore to the extent i can... Many thanks...



0 Likes 0 ·
Erick Ramirez avatar image Erick Ramirez ♦♦ narayana.jayanthi_191238 ·

Did you manage to figure this out? I wonder if you tried to create the KinD cluster when one already exists.

Check with:

$ kind get clusters

If the previous one still exists, the output will be:

0 Likes 0 ·