Ryan Quey avatar image
Ryan Quey asked Erick Ramirez edited

Running "dse nodetool status" returns "/etc/dse/cassandra/ No such file or directory?

Somewhere along the line, while trying out different Cassandra/DSE implementations and versions, I messed up my config files.

Accordingly, when I run

./dse nodetool status

it returns:

/home/ubuntu/lib/dse-6.8.0/resources/cassandra/bin/ line 75: /etc/dse/cassandra/ No such file or directory

Is there a way to get this config file back? Or better, just to totally refresh my DSE 6.8 install so it puts all the default files back?

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered Erick Ramirez edited


It isn't an installation issue. The problem is that this command is invalid:

$ dse nodetool status


The dse tool is for running commands like starting/stopping DSE and launching clients (such as a Spark shell) to connect to a node running DataStax Enterprise.

The nodetool utility is for retrieving information or performing operations on Cassandra. The dsetool utility provides a similar functionality but retrieves information about DSE components or running DSE-specific operations.


To get information about a Cassandra cluster, run:

$ nodetool status

For example:

$ nodetool status
Datacenter: Cassandra
|/ State=Normal/Leaving/Joining/Moving/Stopped
--  Address        Load       Owns (effective)  Host ID                               Token                                    Rack
UN  277.27 MiB  100.0%            38d53689-8039-470c-91c2-4ede83066826  3835820215023312942                      rack1

To get additional information about a DSE cluster such as workload type and node health, run:

$ dsetool status

For example:

$ dsetool status
DC: Cassandra       Workload: Cassandra       Graph: no     
|/ State=Normal/Leaving/Joining/Moving
--   Address          Load             Effective-Ownership  Token                                        Rack         Health [0,1] 
UN    277.27 MiB       100.00%              3835820215023312942                          rack1        1.00

For more information, see DataStax Enterprise Tools. Cheers!

5 comments Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Ryan Quey avatar image Ryan Quey commented ·

Oh yeah, I always forget that it's not officially supported to do it that way. It is strange that it still runs though. Regardless, I get the same result if I do it the correct way:

I can change the question though if it's helpful.


0 Likes 0 ·
1596516994437.png (16.1 KiB)
Erick Ramirez avatar image Erick Ramirez ♦♦ Ryan Quey commented ·

OK, so here's something really curious. You're running the commands in bin/ as if you've got a tarball installation. If this is true, then the script should be in the conf/ directory.

But the script that gets called is looking for in /etc/dse/cassandra which indicates that it's a packaged installation.

Can you tell me how you installed DSE 6.8.0? Also, did you remove the previous package installation(s) before installing DSE 6.8.0?

After looking closely, it indicates that the installations are scrambled on the node. Cheers!

1 Like 1 ·
Ryan Quey avatar image Ryan Quey Erick Ramirez ♦♦ commented ·

Yeah so I have ran DSE on docker, using the debian package installation, and from the tarball all on this Ubuntu server before, as I was playing around with things. Currently I am using the tarball as you mentioned.

I have since removed the docker images (which shouldn't affect things anyways I think) and the package installation (though probably not correctly, hence the errors). It's been too long since I've done it to remember how I removed the package installation as well.

Given that, is there a way to fix it? Or is it beyond repair at this point?

Thanks again though, even diagnosing that the `` script is looking in the wrong place is helpful in itself

0 Likes 0 ·
Show more comments
Erick Ramirez avatar image Erick Ramirez ♦♦ Ryan Quey commented ·

Let me check something, be back shortly...

0 Likes 0 ·