Build Cloud-Native apps with Apache Cassandra

GOT QUESTIONS from the Workshop? You're in the right place! Post a question here and we'll get you answers.

Click here for Week 8 Materials and Homework.

Follow us on Eventbrite to get notified when new workshops are scheduled!


vinayakongovi_192926 avatar image
vinayakongovi_192926 asked vinayakongovi_192926 commented

Can't run "npm start run" on Windows desktop

I am trying to run the astra ui of week4 microservice - locally .the npm start run commands fails to compile and launch the ui

following error

ERROR in Entry module not found: Error: Can't resolve 'run' in 'C:\Vinaya\cloned_repo\cassandra-workshop-series\week4-AppDev-api\getting-started-with-astra-ui'
ERROR in multi (webpack)-dev-server/client?http://localhost:3000 (webpack)/hot/dev-server.js run
Module not found: Error: Can't resolve 'run' in 'C:\Vinaya\cloned_repo\cassandra-workshop-series\week4-AppDev-api\getting-started-with-astra-ui'
@ multi (webpack)-dev-server/client?http://localhost:3000 (webpack)/hot/dev-server.js run main[2]
Child html-webpack-plugin for "index.html":
1 asset
Entrypoint undefined = index.html
[./node_modules/html-webpack-plugin/lib/loader.js!./src/index.html] 520 bytes {0} [built]
[./node_modules/lodash/lodash.js] 528 KiB {0} [built]
[./node_modules/webpack/buildin/global.js] (webpack)/buildin/global.js 472 bytes {0} [built]
[./node_modules/webpack/buildin/module.js] (webpack)/buildin/module.js 497 bytes {0} [built]
i 「wdm」: Failed to compile.


Hi Erick, I tried npm run start and this is the response -UI is not getting launched

C:\Vinaya\cloned_repo\cassandra-workshop-series\week4-AppDev-api\getting-started-with-astra-ui>npm run start
> getting-started-with-apollo-ui@1.0.0 start C:\Vinaya\cloned_repo\cassandra-workshop-series\week4-AppDev-api\getting-started-with-astra-ui
> cross-env NODE_ENV=development webpack-dev-server -d
'cross-env' is not recognized as an internal or external command,
operable program or batch file.
npm ERR! errno 1
npm ERR! getting-started-with-apollo-ui@1.0.0 start: `cross-env NODE_ENV=development webpack-dev-server -d`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the getting-started-with-apollo-ui@1.0.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\vinnu\AppData\Roaming\npm-cache\_logs\2020-07-29T20_29_32_367Z-debug.log
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Erick Ramirez avatar image
Erick Ramirez answered Erick Ramirez commented

The command is:

npm run start

Could you please confirm that you ran the correct command? Cheers!

2 comments Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

[Update published in the original question above]

0 Likes 0 ·

And what did it say in the logs? Any clues?

0 Likes 0 ·
bettina.swynnerton avatar image
bettina.swynnerton answered vinayakongovi_192926 commented

Hi @vinayakongovi_192926,

if you get compile errors with the UI at this stage, they are most likely due to the required .env file not being available or not in the right place.

You need to have a .env file in the getting-started-with-astra-ui directory, containing the base address for the UI:

The base address is different, depending on the API in use. For Java, when running locally, it should look like this:


See here:

I hope this gets you to the next stage, let us know how you get on.

1 comment Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hi Bettina.I tried the suggestion,still no luck

I think it has to do with npm updates.WIll try pulling the code from git and running again sometime over teh weekend


0 Likes 0 ·
week4-ui.png (140.6 KiB)