Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

prakash_ganesan_174223 avatar image
prakash_ganesan_174223 asked ·

Why am I getting a warning for mixed DSE versions when upgrading through LCM?

when i try to upgrade 6.0.5 to 6.0.7 LCM jobs getting failed gave below error

cloned configure file from current version 6.0.5 and try to upgrade starting from seed node


upgrade
1566564547343.png (46.5 KiB)
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

@prakash_ganesan_174223 it means the cluster you are trying to upgrade has 2 different versions -- some nodes are running DSE 6.0.5 and some are DSE 6.0.9.

You will not be able to upgrade the nodes with LCM while the cluster has mixed versions. You will have to manually upgrade the nodes running with DSE 6.0.5 to 6.0.9. Cheers!

1 comment Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

All nodes are running same version but still am getting same error in LCM


cassandra@cqlsh> select release_version from system.peers;


release_version

-----------------

4.0.0.605

4.0.0.605


(2 rows)

cassandra@cqlsh> select release_version from system.local;


release_version

-----------------

4.0.0.605


Thanks
prakash

0 Likes 0 · ·