DataStax Academy FAQ

DataStax Academy migrated to a new learning management system (LMS) in July 2020. We are also moving to a new Cassandra Certification process so there are changes to exam bookings, voucher system and issuing of certificates.

Check out the Academy FAQ pages for answers to your questions:


question

talino2321 avatar image
talino2321 asked ·

Why can't I get OpsCenter to start for DS210? Getting "Detected Java version 11.0.7"

following the lab exercise for DS210 Lab Exercise (OpsCenter). It appears to properly install the opscenter via apt-get (O/S is Ubuntu 18.04 LTS with jdk v. 11.0.7). after changes to the opscenter.conf to put in my external ip address. I run 'sudo service opscenterd start' . I check the status of the service and see the following

root@ds210-node3:/etc/opscenter# sudo service opscenterd status
● opscenterd.service - LSB: Cassandra cluster manager
Loaded: loaded (/etc/init.d/opscenterd; generated)
Active: active (exited) since Wed 2020-07-22 01:57:59 UTC; 2s ago
Docs: man:systemd-sysv-generator(8)
Process: 5307 ExecStop=/etc/init.d/opscenterd stop (code=exited, status=0/SUCCESS)
Process: 5378 ExecStart=/etc/init.d/opscenterd start (code=exited, status=0/SUCCESS)

Jul 22 01:57:58 ds210-node3 systemd[1]: Starting LSB: Cassandra cluster manager...
Jul 22 01:57:59 ds210-node3 opscenterd[5378]: Detected Java version 11.0.7
Jul 22 01:57:59 ds210-node3 systemd[1]: Started LSB: Cassandra cluster manager.

I suspect it maybe the jdk version. But accordingly that version is the correct version for Ubuntu 18.04.

Any ideas on how to get it running?

academyopscenterds210
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Erick Ramirez avatar image
Erick Ramirez answered ·

OpsCenter only supports Java 8. Java 11 isn't a supported version.

I recommend you install OpenJDK 8. The high-level steps on Ubuntu are:

Step 1 - Update the repositories:

$ sudo apt-get update

Step 2 - Install OpenJDK 8:

$ sudo apt-get install openjdk-8-jdk

It might also be necessary to force a switch to Java 8. For example:

$ sudo update-alternatives --set java /usr/lib/jvm/jdk1.8.0_242/bin/java

For details of all the required steps, see Installing Open JDK 8 on Debian or Ubuntu Systems. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

talino2321 avatar image
talino2321 answered ·

Thanks for the idea on how to get it running. I took what you provided, and with a little creative effort got it running. Here is what I had to do to actually get it running.

  1. remove all of the openjdks -- sudo apt-get purge --auto-remove openjdk*
  2. remove the opscenter -- sudo apt-get purge --auto-remove opscenter
  3. install openjdk 8 -- sudo apt-get install openjdk-8-jdk
  4. install opscenter -- sudo apt-get install opscenter
  5. edit the opscenter.conf to put my external ip addr in -- sudo vi /etc/opscenter/opscenterd.conf
  6. start the service -- sudo service opscenterd start

I tried just adding the openjdk-8 but apparently during the original install of opscenter, it linked to the jdk-11 path. So I was still getting the same issue even after running the sudo update-java-alternatives --set /usr/lib/jvm/java-1.8.0-openjdk-amd64 command. I might of gotten around that by removing opscenter and reinstalling, but reading some other responses in various forums about mix jdk versions causing problems, most recommended only having a single version installed.

I do have a major concern that opscenter is still on jdk 8. Datastax really needs to get it running on 11 or newer.


Jim

1 comment Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Good to hear you got it running.

And thanks for the feedback about Java 11 not being supported. This is unfortunately not in our control. DSE has dependencies on third-party software which do not support Java 11. To top it off, Java 11 support is still experimental in Cassandra (CASSANDRA-9608). Cheers!

0 Likes 0 · ·