david.nigh_186724 avatar image
david.nigh_186724 asked Erick Ramirez edited

Why can't I untar dse-6.0.0-bin.tar.gz in the DS201 VM image?

After importing the ubuntu ds201 VM into VirtualBox 6.1 on Windows 10, I run the command:

tar -xf dse-6.0.0-bin.tar.gz

I get the following result:

I'm trying to take the 8 week training course and cannot get past this hurdle, any help is much appreciated, thanks!

snpip.png (92.0 KiB)
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

preethikoluvaiya23_193353 avatar image preethikoluvaiya23_193353 commented ·

Hi. I am also facing the same issue..As per your instruction, i tried checksum. Got same result for command1, but different for command2 and validatihg OVA. Attached screen capture for reference. Please guide me what should I do?

0 Likes 0 ·
error.jpg (60.1 KiB)
bettina.swynnerton avatar image bettina.swynnerton ♦♦ preethikoluvaiya23_193353 commented ·

Hi @preethikoluvaiya23_193353,

you should be getting this checksum for the tar:

3517560460 911703665 dse-6.0.0-bin.tar.gz

Your checksum is 2051...

Unfortunately this means that the tar is incomplete.

If you want to check the checksum of the VM file DS201-VM-6.0.ova, you will need to do this on the host itself, you can't run it from within the VM.

You could try to download a new dse-6.0.0-bin.tar.gz, if your VM has a network connection. This would probably be faster than downloading the whole VM again.

In your VM, move the existing dse-6.0.0-bin.tar.gz file to a new name, and download the tar file again:

mv dse-6.0.0-bin.tar.gz old-dse-6.0.0-bin.tar.gz

I hope this gets you over this hurdle.

0 Likes 0 ·

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered Erick Ramirez edited

There are two things I wanted to bring to your attention.

First, you are getting an error when unpacking the tarball because you're using the wrong command. The tarball is also zipped so you need to specify the -z flag to unzip it:

$ tar xzf dse-6.0.0-bin.tar.gz

Second, for the purposes of the workshop, it isn't necessary to perform the exercises. We asked you to watch the videos in the DS201 Academy course to reinforce the concepts discussed in week 1 of the workshop.

But if you would like to complete the exercises, by all means please do. Cheers!

[EDIT] It looks like the tarball is corrupted. Verify the file type and checksum against these:

$ file dse-6.0.0-bin.tar.gz
dse-6.0.0-bin.tar.gz: gzip compressed data, from FAT filesystem (MS-DOS, OS/2, NT)
$ cksum dse-6.0.0-bin.tar.gz 
3517560460 911703665 dse-6.0.0-bin.tar.gz

In addition, validate the OVA file you downloaded against this checksum:

$ cksum DS201-VM-6.0.ova
535688765 2881041408 DS201-VM-6.0.ova

If any of the above don't match, it will confirm that your copy is corrupted and you will need to download the VM again. Cheers!

2 comments Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

david.nigh_186724 avatar image david.nigh_186724 commented ·

thanks for the response Erick. I was just following the instructions specified in Exercise 1, step 2, for installing and starting Cassandra here:

I tried your tar command with the -z flag and get this error:

Also if I try the gunzip command, I get:

0 Likes 0 ·
1593955296364.png (30.4 KiB)
1593955377585.png (64.3 KiB)
1593955682666.png (21.0 KiB)
Erick Ramirez avatar image Erick Ramirez ♦♦ david.nigh_186724 commented ·

[EDITED] I've updated my answer. Cheers!

0 Likes 0 ·