DataStax Academy FAQ

DataStax Academy migrated to a new learning management system (LMS) in July 2020. We are also moving to a new Cassandra Certification process so there are changes to exam bookings, voucher system and issuing of certificates.

Check out the Academy FAQ pages for answers to your questions:


question

scano_183208 avatar image
scano_183208 asked ·

Attempts to run Gremlin commands in Studio returns "All DSE gremlin server hosts are currently down"

When I attempt to make a simple system.graphs() via DSE Studio I receive the following error:

"All DSE gremlin server hosts are currently down or don't have the 'graph' workload set. Please make sure that hosts are available and have the 'graph' workload, and then try again."

Ive know that all nodes are running a graph workload.

In case im mistaken where can i check that the graph workload is enabled? what other troubleshooting steps should i take? Are there any logs i can look at?


Any insight or help on this is appreciated.


Thank you,

Simon


studiogremlin
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

@scano_183208 The symptoms you described indicates that Studio cannot connect to the gremlin server port for DSE Graph. The default port is 8182.

To check if nodes in the DC you are connecting to have Graph workload enabled, run the following command and the "Graph" column should indicate "yes":

$ dsetool ring

Once you've confirmed that Graph is enabled, check that the nodes are listening on port 8182 by running either of these commands:

$ netstat -tnlp
$ sudo lsof -nPi | grep LISTEN

Finally, verify that there are no firewalls blocking traffic between Studio and the nodes in your cluster. If the cluster is firewalled, check that the ports used by DSE have ingress rules defined. For more info, see Securing DataStax Enterprise ports. Cheers!

8 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

@Erick Ramirez Looks like everything checks out. Nodes are listening on 8182 and graph workload is enabled. I am using azure VM's and i double checked that the network inbound rules allow traffic through port 8182 and 10000 for AOSS (this is also not working via studio)

This is my current node config on LCM where 192 is the private and 104 is the public IP:

0 Likes 0 · ·
1589378259556.png (25.9 KiB)

@scano_183208 Unfortunately, that doesn't provide the required information from the netstat or lsof outputs. Studio needs to connect to the public IP but only if the ports are bound to 0.0.0.0.

0 Likes 0 · ·
scano_183208 avatar image scano_183208 Erick Ramirez ♦♦ ·

@Erick Ramirez what should the correct combination of IP's be? Im still a little confused

0 Likes 0 · ·
Show more comments

@scano_183208 I can see from your latest update that the clients are listening on all interfaces:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:9042            0.0.0.0:*               LISTEN      -
tcp        0      0 0.0.0.0:9077            0.0.0.0:*               LISTEN      -
tcp        0      0 0.0.0.0:8182            0.0.0.0:*               LISTEN      -

You should connect to IP 104.41.137.195 from Studio. You should also make sure that there is network connectivity between the machine where you run Studio and your cluster on Azure. Cheers!

0 Likes 0 · ·