Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

uttkarsh.jain_159863 avatar image
uttkarsh.jain_159863 asked ·

Best practice to have Search enabled with DSE

we have 3 nodes cluster on the same datacenter and out which 2 are seed nodes and one of the seed node we have SOLR_ENABLED=1 enabled. we are facing an issue when we enable search and load a search index it errors out saying not able to connect to <ip>:9042.

What is the best practice to have solr enabled in DSE? Considering its just three-node cluster.


dsesearch
1564049117908.png (165.2 KiB)
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Erick Ramirez avatar image
Erick Ramirez answered ·
we have 3 nodes cluster on the same datacenter and out which 2 are seed nodes and one of the seed node we have SOLR_ENABLED=1 enabled.

@uttkarsh.jain_159863 best practice is to isolate each workload in its own DC so in your case, you should have one DC with pure-Cassandra nodes and a separate DC with nodes running in DSE Search mode.

See DSE Search architecture for more info. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

David Jones-Gilardi avatar image
David Jones-Gilardi answered ·
we have 3 nodes cluster on the same datacenter and out which 2 are seed nodes and one of the seed node we have SOLR_ENABLED=1 enabled.

Adding to what @Erick Ramirez said I would also ensure that you have Search enabled on all of the nodes in your DC. From your comment it sounded like you only have Search enabled on 1 of 3 nodes.

4 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks, David for the comment. Just to clarify more on this i am using DSE 6.7.4. Now, lets saw we have 2 DC's so one DC with 3 nodes should have DSE Graph Enabled and DC2 with 3 nodes should have DSE Search enabled . in short, Graph Nodes has nothing to do DSE_SOLR property and similarly DSE Solr has nothing to with DSE Graph Property.


0 Likes 0 · ·

DSE Graph is not a type of workload but a database model. If you are using Graph, you need to enable it on ALL nodes in the cluster. Cheers!

0 Likes 0 · ·
in short, Graph Nodes has nothing to do DSE_SOLR property and similarly DSE Solr has nothing to with DSE Graph Property.

In a general sense, correct, Graph and Search/Solr are different tightly integrated technologies within DataStax Enterprise. You could enable Graph and Search on all of the same nodes if you wanted without worry they would affect each other.

0 Likes 0 · ·

However, they can work together. Graph traversals can leverage Search/Solr indexes for global indexing -> https://docs.datastax.com/en/dse/6.7/dse-dev/datastax_enterprise/graph/using/indexing.html#Globalindexingoverview so there are benefits to using them together.

0 Likes 0 · ·
Mike_201 avatar image
Mike_201 answered ·

I'm guessing, based on your attached image, that your external IP address is not listening on port 9042. Instead, try specifying the host when you run dsetool

dsetool -h localhost reload_core ... and so on
2 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hello Mike,

Even doing this is not helping me. nodetool status shows me all the nodes are up

However, doing any action with dsetool is throwing me this exception.

0 Likes 0 · ·
1564337017123.png (82.8 KiB)
1564337048556.png (38.5 KiB)

Here is the sequence which I tried and this is what the behavior is.

1. I try to reload_core with below command

dsetool reload_core orbigo.state_p reindex= true deleteall=false

This errored showing ramBufferSize not supported, Changed it and then. dsetool isn't able to connect to server even with host specified.

2. restarting the node fixes this issue.

0 Likes 0 · ·