Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

uttkarsh.jain_159863 avatar image
uttkarsh.jain_159863 asked ·

Datastax Graph . Vertex exists but underline table are deleted

Hi,

we created one vertex as “suburb” using the studio and now we tried to load the data using graph-loaders and csv. Eventually, there was something wrong in groovy and it dint loaded all the data properly. so , we removed all the loaded vertices like g.V().hasLabel(“suburb”).drop().

we re-loaded the data and it loaded fine but again due to some discrepancies. we tried deleting the sub-urb schema like schema.VertexLabel(“suburb”).drop() and it gives me an error like suburb_p table does not exits.

we tried verifying the table by connecting to cqlsh and the tables suburb_p and suburb_e were not there.

i tried all the options like restart, refresh but nothing is working. could you please help

graphdatastax gr
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

dave.bechberger avatar image
dave.bechberger answered ·
  1. I would start by determining why the node 45.32.250.18 is down and bring it back online.
  2. Once it is back online I would make sure that the schema versions are in agreement. If not then I would follow this guide. Handling Schema Disagreements
  3. Once that is back online I would first check to see if you have any further issues with your graph schema. If so you may need to try dropping the vertex label again.


As a general rule, you don't want to do any schema modifications when any nodes in the cluster are down to avoid the scenario you are currently in where the schema versions on different nodes are not in agreement.


Which version of DSE are you running? If you don't know you can run


dse -v
3 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

We are using DSE 6.0.0.

Thanks for the reply and steps. I will work on it. However, while starting the node which is down I am seeing this exception.

0 Likes 0 · ·
1564031329701.png (139.5 KiB)

I would suggest following the procedures outlined here: Replacing a dead node


I would also suggest you update to a newer version of DSE as the current is 6.0.9 and has many bug fixes included from your version. See the release notes here.

0 Likes 0 · ·

Thanks, alot Dave

0 Likes 0 · ·
dave.bechberger avatar image
dave.bechberger answered ·

If I understand this correctly

schema.VertexLabel(“suburb”).drop()

which removed the suburb vertex from the graph schema but you recieved an error that suburb_p did not exist, and you have verified this via CQLSH and this appears to be the case.

Is this correct?

If so do you see the suburb vertex if you run:

schema.describe()


Just for some baseline info here:

Which version of DSE are you running?

Are you running in a multi-node cluster?

If you are in a multi-node cluster can you please run

 nodetool describecluster 

and see if there is a schema version mismatch.

1 comment Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Hello Dave,

yes, you are right, I received an error while dropping suburb I verified it via cqlsh and suburb_p and suburb_e tables are not there.

When I do schema describe it does show me a suburb in there.

Schema.describe()

Yes, I am running a multi-node (3 nodes) cluster, out of which I noticed one node was down when I was dropping the vertex.


0 Likes 0 · ·
1564027361064.png (50.7 KiB)