Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

amitosh avatar image
amitosh asked ·

downgrade from dse 6.1 to 5.1.16

hi team i am downgrading from dse 6.1 to 5.1.16

is there any particulars i need to take care off ?? while downgrade ?

After running the installation for 5.1.16 I am getting lots of errors from dse.yaml


Also after using new yaml file getting error like

CassandraDaemon.java:731 - Detected unreadable sstables /var/lib/cassandra/data ......

downgrading dse
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

@amitosh you cannot just downgrade the binaries after you have already upgraded a node. You need to resolve the problem on the node then upgrade the rest of the nodes in the cluster. If you really can't resolve the issue, you will need to uninstall DSE then clear all directories and restore from a previous backup. For details, see Rolling back an upgrade. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.