igor.rmarinho_185445 avatar image
igor.rmarinho_185445 asked Erick Ramirez answered

Failed to create search index with "InvalidRequest: Error from server: code=2200 [Invalid query]"

Hi guys!

I have one more problem that I can't find a reliable source to fix my issue, I'm trying to fix it since yesterday without success.

I have the problem below

cqlsh:pcommon_employee> DROP SEARCH INDEX ON  pcommon_employee.employee_by_id;
user@cqlsh:prodchngcpcommon_employee> CREATE SEARCH INDEX IF NOT EXISTS ON  prodchngcpcommon_employee.employee_by_id;
InvalidRequest: Error from server: code=2200 [Invalid query] message="Failed to create search index pcommon_employee.employee_by_id because: Create for core pcommon_employee.employee_by_id failed on the following nodes: [/30.*.50.4, /30.*.50.3].
Please try reloading the core.

If I try to reload the core nodes: [/30.*.50.4, /30.*.50.3] I got this msg:

node-2 ~]$ dsetool reload_core pcommon_employee.employee_by_id deleteAll=true reindex=true 
Failed to reload search index ppcommon_employee.employee_by_id because: No resource solrconfig.xml for core pcommon_employee.employee_by_id, did you miss to upload it?

Anyone have a clue about it?

1 comment
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

igor.rmarinho_185445 avatar image igor.rmarinho_185445 commented ·


I dropped the index did a repair -pr, restarted the node and created the index from another node and worked, but still not sure of what happened.

0 Likes 0 ·

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

@igor.rmarinho_185445 The most common cause of the problem you described is nodes in the cluster being down or unresponsive. Specifically for your case, the node where you were running cqlsh couldn't connect to these two nodes -- [/30.*.50.4, /30.*.50.3]. You will need to check the logs to determine why the were not responding at the time.

When you re-ran the command on another node, the nodes in your cluster were responsive so the core was created successfully. Cheers!

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.