DataStax Academy FAQ

DataStax Academy migrated to a new learning management system (LMS) in July 2020. We are also moving to a new Cassandra Certification process so there are changes to exam bookings, voucher system and issuing of certificates.

Check out the Academy FAQ pages for answers to your questions:


question

pramod.dba31_92912 avatar image
pramod.dba31_92912 asked ·

APT installing DSE 6.7 packages when installing DSE 6.0.11

Following instructions from this link on my test machine.

https://docs.datastax.com/en/install/6.0/install/installDEBdse.html

root@pramod03:~# apt-get install dse-full=6.0.11-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
dse-full : Depends: dse (= 6.0.11-1) but 6.7.7-1 is to be installed
Depends: dse-libgraph (= 6.0.11-1) but 6.7.7-1 is to be installed
Depends: dse-libsolr (= 6.0.11-1) but 6.7.7-1 is to be installed
Depends: dse-libtomcat (= 6.0.11-1) but 6.7.7-1 is to be installed
Depends: dse-liblog4j (= 6.0.11-1) but 6.7.7-1 is to be installed
Depends: dse-libspark (= 6.0.11-1) but 6.7.7-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Don't understand why its asking some thing related to 6.7 although trying for 6.0

dseinstallation
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

@pramod.dba31_92912 DSE 6.0.11 is no longer the latest version. The latest version is DSE 6.7.7 so you need to explicitly specify the version for all packages as stated in step 6 of that link you provided like this:

$ sudo apt-get install \
  dse=6.0.11-1 \
  dse-full=6.0.11-1 
  dse-libcassandra=6.0.11-1 \
  dse-libgraph=6.0.11-1 \
  dse-libhadoop2-client-native=6.0.11-1 \
  dse-libhadoop2-client=6.0.11-1 \
  dse-liblog4j=6.0.11-1 \
  dse-libsolr=6.0.11-1 \
  dse-libspark=6.0.11-1 \
  dse-libtomcat=6.0.11-1

Thanks for bringing this to our attention. I will get the document updated to make it clearer. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.