PLANNED MAINTENANCE

Hello, DataStax Community!

We want to make you aware of a few operational updates which will be carried out on the site. We are working hard to streamline the login process to integrate with other DataStax resources. As such, you will soon be prompted to update your password. Please note that your username will remain the same.

As we work to improve your user experience, please be aware that login to the DataStax Community will be unavailable for a few hours on:

  • Wednesday, July 15 16:00 PDT | 19:00 EDT | 20:00 BRT
  • Thursday, July 16 00:00 BST | 01:00 CEST | 04:30 IST | 07:00 CST | 09:00 AEST

For more info, check out the FAQ page. Thank you for being a valued member of our community.


question

mtoolsidas avatar image
mtoolsidas asked ·

Why do the notebooks not load in Studio on startup?

I have Studio 2.0.0 installed. When I start it up, none of the example notebooks load. When I click to create a new notebook, enter a name, and select a connection, it then proceeds to just hang on the gray screen with the spinning wheel. Anyone else experience this? The download seemed to be perfectly fine.

studio
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Dan Jatnieks avatar image
Dan Jatnieks answered ·

What kind of installation environment do you have?

It could be a problem with the Studio user data directory. This is typically in ~/.datastax_studio on linux/macos. Try starting Studio with a clean data directory:

  • Stop Studio
  • Rename the current data directory, e.g. 'mv ~/.datastax_studio ~/.datastax_studio_backup'
  • Restart Studio

You can also check the 'studio.log' file located at <studio-install-dir>/logs any errors that may be logged there.

1 comment Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thank you! This was it! It must have been pointing to the same data directory even across multiple installation methods which is why it was always the same.

1 Like 1 · ·
BarrieByron avatar image
BarrieByron answered ·

@mtoolsidas as a start, have you followed the configuration steps advised in the DataStax Studio docs? https://docs.datastax.com/en/dse/5.1/dse-dev/datastax_enterprise/studio/stdToc.html and checked available troubleshooting https://docs.datastax.com/en/dse-trblshoot/doc/troubleshooting/trblStudio.html


2 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Yes. It works elsewhere find with identical environment conditions.

0 Likes 0 · ·

P.S. @mtoolsidas I've converted your reply to a comment since it's not an "answer". Cheers!

0 Likes 0 · ·