question

Paul043 avatar image
Paul043 asked Erick Ramirez answered

javax.net.ssl.SSLHandshakeException: The client supported protocol versions [TLSv1.3] are not accepted by server preferences [TLS12, SSL20Hello]

javax.net.ssl.SSLHandshakeException: The client supported protocol versions [TLSv1.3] are not accepted by server preferences [TLS12, SSL20Hello]

Please provide the following info to resolve this error:

  1. Datastax Python driver version
  2. The setting in the python code
  3. Datastax Cassandra DSE version on the server

Current Cassandra DSE server version: 5.1.17

Current Datastax Python driver: 3.9

python driver
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

As I advised you previously, Cassandra does not support TLS v1.3 yet (see CASSANDRA-15048). Cheers!

Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.