anjay.prasad avatar image
anjay.prasad asked smadhavan commented

Why does upgrading to DSE 6.8.13 install the latest version?

My current version of DSE was DSE 6.7.10 and was trying to move to 6.8.13. But when I ran
yum update dse-6.8.13 by it installed DSE v6.8.14.
I also tried to run yum install dse-6.8.13 and still DSE v6.8.14 got installed.

Let me know if this is the expected behavior or am I doing it wrong?

And how can I downgrade to DSE 6.8.13 from 6.8.14

1 comment
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

smadhavan avatar image smadhavan ♦ commented ·

@anjay.prasad, whatever Erick has mentioned below, but I would recommend you to take a look at the latest patch version (i.e. 6.8.14) so you consume the latest patches, bug fixes and improvements that are otherwise unavailable with a older patch version i.e. 6.8.13 in your case. Refer to the DSE 6.8 release notes for more details.

0 Likes 0 ·

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

This isn't an issue with DSE itself but just how the package manager works. When using YUM to install software, by default it will pull down the latest version of the package.

Since you want to install a specific version that is not the latest, you need to be explicit with YUM by specifying the version you want for all the packages as documented in the installation procedure. For example:

$ sudo yum install dse-6.8.13-1 \
    dse-full-6.8.13-1 \
    dse-libgraph-6.8.13-1 \
    dse-libcassandra-6.8.13-1 \
    dse-libhadoop2-client-6.8.13-1 \
    dse-libsolr-6.8.13-1 \
    dse-libtomcat-6.8.13-1 \
    dse-liblog4j-6.8.13-1 \

If you have any follow up questions, please log a ticket with DataStax Support so one of our engineers can work with you directly. Cheers!

10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.