anirbandatta avatar image
anirbandatta asked Erick Ramirez commented

DataStax Desktop 2.3.0 issue with Docker 20.10.7

Dear All,

I have installed docker 20.10.7 and started the docker service and enabled it . The docker hello word , is working fine and the status was also showing active and running.

However, when I run the Datastax desktop, it is saying Docker 20.10.7 installed but not running and hence I am not able to perform anything on the desktop.

Would anyone help me with this please? Is this a version mismatch issue or some user issue, with which I am running the services. I have used root to install the docker and then given a user sudo permission to run the docker.


datastax desktop
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered Erick Ramirez commented

[UPDATED] I have tried to replicate the issue you reported by installing Docker Engine v20.10.7 but it is working for me.

After starting Docker Engine successfully, I am able to start DataStax Desktop without issues:

1. Docker installed and started
Docker v20.10.7 is installed and running

Based on the information you provided, I can only conclude that Docker Engine is not running on your system so you need to resolve that first before you can run DataStax Desktop.

If you're running on Ubuntu, you will need to configure Docker to run as a non-privileged user. Cheers!

[UPDATE v2] It looked to me like you are running on Linux so I've installed Ubuntu 20.04 Desktop. I can confirm that I can replicate the issue you reported when Docker requires root privilege.

When you start DataStax Desktop as an ordinary user, it isn't able to run docker commands so it thinks the Docker Engine isn't running.

Once I've added my login to the docker group in Ubuntu:

$ sudo usermod -aG docker $USER

(requires that you logout of your session completely then log back in), I am able to run DataStax Desktop on an Ubuntu machine:


2 comments Share
10 |1000

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

anirbandatta avatar image anirbandatta commented ·
Thanks Erick. It worked. I am using OEL 8.
0 Likes 0 ·
Erick Ramirez avatar image Erick Ramirez ♦♦ anirbandatta commented ·

Not a problem. Cheers!

0 Likes 0 ·