Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

phaniharsha avatar image
phaniharsha asked Erick Ramirez answered

Issues with deploying 1.1.0 operator using CRD from cass-operator 1.6.0

Hi Team,

We have upgraded the Cassandra operator from 1.1.0 to 1.6.0 as per the following documentation.
https://docs.datastax.com/en/cass-operator/doc/cass-operator/cassOperatorUpgrades.html

No issues have been found in the 1.6.0 version and we are trying to deploy the 1.1.0 operator using existing 1.6.0 configurations(such as CRD, cluster role, and role bindings) but seeing few errors in the operator pod. however, the operator pod is up and running and able to bring up the Cassandra cluster ( Cassandra statefulset is deploying and cluster-dc1 pods are up and running) - can you please assist us with errors?

PFA - error'soperator-errors.txt

Besides, regarding cassandra operator 1.6.0, would it be recommended to use in a production environment?

cass-operator
5 comments
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

What does `kubectl get apiservices` return?

0 Likes 0 ·
phaniharsha avatar image phaniharsha john.sanda_194109 ·

Hi @john.sanda_194109

here it is

kubectl get apiservices v1beta1.cassandra.datastax.com -o yaml
apiVersion: apiregistration.k8s.io/v1
kind: APIService
metadata:
  creationTimestamp: "2021-05-06T07:19:38Z"
  labels:
    kube-aggregator.kubernetes.io/automanaged: "true"
  name: v1beta1.cassandra.datastax.com
  resourceVersion: "554635311"
  selfLink: /apis/apiregistration.k8s.io/v1/apiservices/v1beta1.cassandra.datastax.com
  uid: 31753571-0f3a-4a8f-b82b-cf2ff8fdd012
spec:
  group: cassandra.datastax.com
  groupPriorityMinimum: 1000
  version: v1beta1
  versionPriority: 100
status:
  conditions:
  - lastTransitionTime: "2021-05-06T07:19:38Z"
    message: Local APIServices are always available
    reason: Local
    status: "True"
    type: Available


Please let me now if you need anything else.


Thanks,
Phani

0 Likes 0 ·

Are you trying to deploy version 1.1.0 of the operator using the CRD from 1.6.0? If so, why? Why not using the corresponding version of the operator?

0 Likes 0 ·
Show more comments

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered

What you're trying to do doesn't make sense to me. Deploying cass-operator 1.1.0 with the CRD from version 1.6.0 isn't supported.

It's definitely not something we test because again, it doesn't make sense to do so. In one of your comments, you mentioned that you want to be able to downgrade the operator but it isn't a good idea because you potentially break your Cassandra further.

The ideal action is to resolve any underlying problem you have with the cluster instead of downgrading because if you're using any feature in a new version of the operator, it will stop working when you downgrade to an older version. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.