Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

Naraen avatar image
Naraen asked ·

Is Python 3 supported in Cassandra 3.11.6?

hi @Erick Ramirez

We use Cassandra 3.11.6 and cqlsh 5.0.1. Recently we upgraded to py3. We are unable to use cqlsh after the py upgrade.

Error: No appropriate python interpreter found.

We tried using cqlsh 6.0.0 version. but desc command doesnt work

[cqlsh 6.0.0 | Cassandra 3.11.6 | CQL spec 3.4.4 | Native protocol v4]
Use HELP for help. 
cassandra@cqlsh> desc keyspaces; 

Other commands work fine in cqlsh. So is there any fix/work around for this issue?

cqlsh
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered ·

Cassandra 3.11 does not support Python 3. It is only supported in Cassandra 4.0 (CASSANDRA-15659).

You will need to install Python 2.7 as documented in Installing Cassandra. Cheers!

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.