Bringing together the Apache Cassandra experts from the community and DataStax.

Want to learn? Have a question? Want to share your expertise? You are in the right place!

Not sure where to begin? Getting Started

 

question

mjcarey_178232 avatar image
mjcarey_178232 asked mjcarey_178232 commented

Next button in last step of Astra Data Loader stays disabled

I am experimenting with Astra (free tier) in preparation for teaching 150 students about Cassandra (among other technologies) in a few weeks. I'm trying to make sure they will be able to upload data - but the loader is not cooperating. I'm getting at it from the "Upload Data" button on the Astra console - looks like a nice easy-to-use utility. I'm trying to upload a tiny CSV with a handful of test rows - I get all the way to the last step, select my target keyspace, and am expecting Next to be enabled to finish the job. BUT - Next never gets highlighted - I am stuck at that point. WHAT AM I MISSING? Help! Thanks! Attached are two screenshots showing (i) a successful upload and the ability to provide key specs and say "Next", and then the screen beyond which I can't proceed. (They are in reverse order below, sorry.) I'd love to figure this out FAST - I have a class to teach.... Thx!stuckloader.pngalmostloaded.png

astrabulk loader
almostloaded.png (297.6 KiB)
stuckloader.png (205.4 KiB)
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

1 Answer

Erick Ramirez avatar image
Erick Ramirez answered mjcarey_178232 commented

[UPDATED] The Astra team identified the code in the last release that introduced a bug in the UI.

The fix is scheduled for release tomorrow (Pacific time). Cheers!

7 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Any updates? I can't believe that Astra's data upload feature is broken for everyone - maybe I'm missing some Next-enabling click or something in the near-final step? (I can't see what, though, and I tried a different CSV even though the one I'd tried before seemed to be fine as far as the uploader was concerned.) I'd love to be unstuck soon....

0 Likes 0 ·

Question asked 3 days ago. Still no update or resolution?

0 Likes 0 ·

No update or resolution fo this "urgent resolution" request from 3 days ago?

0 Likes 0 ·

I apologise that this is taking longer than expected.

In the meantime, you can use the DataStax Bulk Loader to load data to your database as a workaround.

I'm sorry that I can't give any estimate as to when the issue will be resolved by Engineering. Cheers!

0 Likes 0 ·

The team is releasing the fix tomorrow. I've updated my response accordingly. Cheers!

0 Likes 0 ·
Show more comments