DataStax Academy FAQ

DataStax Academy migrated to a new learning management system (LMS) in July 2020. We are also moving to a new Cassandra Certification process so there are changes to exam bookings, voucher system and issuing of certificates.

Check out the Academy FAQ pages for answers to your questions:


question

seleukos avatar image
seleukos asked ·

Unable to start node2 in exercise 02.01 of DS210 course

Currently I'm working on the DS210 course, and trying for the second time to get the three-node-cluster working (second attempt with fresh VM and configuring the nodes).

Unfortunately, node2 is not starting and running. I already found following question:

https://community.datastax.com/questions/7363/not-able-to-setup-a-second-dc-in-ds210-exercise.html

But this didn't help me either. Following the recommendation to check log files on node2, proved unsuccessful. As it seems, log files are not written (yesterday evening) at all or not written, when command 'sudo service dse start' is given on CLI (aside two entries from today, but had more attempts). node1 and node3 running as expected (hopefully).

I also tried to find configuration errors on my side several times (found some and corrected on other node), but didn't find a solution.

Are there any options left I can try?

I'm referring to exercises in Exercise 02.01.

academyds210
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

seleukos avatar image
seleukos answered ·

Solution found: It seems, giving the VM 8 or 12 GB RAM, instead of the preconfigured 6 GB was the problem. With 6 GB RAM it seems all fine (by now).

Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Erick Ramirez avatar image
Erick Ramirez answered ·

If no logs are getting generated at all, that indicates that there's a problem at the operating system level.

Try starting DSE using the init script in /etc/init.d to see if errors are generated:

$ sudo /etc/init.d/dse start

You'll need to use all the knowledge you've gained from the previous exercises to troubleshoot this problem. It's likely a configuration issue that's preventing the node from starting. Cheers!

2 comments Share
10 |1000 characters needed characters left characters exceeded

Up to 8 attachments (including images) can be used with a maximum of 1.0 MiB each and 10.0 MiB total.

Thanks for your suggestion, but it didn't work for me:

ubuntu@ds210-node2:~$ sudo /etc/init.d/dse start
 * Starting DSE daemon dse                                                                                                    
DSE daemon starting with only Cassandra enabled (edit /etc/default/dse to enable other features)
/etc/init.d/dse: 503: ulimit: error setting limit (Operation not permitted)
WARNING: Timed out while waiting for DSE to start. The service may have started though. Please check your logs.
                                [fail]
ubuntu@ds210-node2:~$ sudo /etc/init.d/dse status
 * dse is not running

With some work, I got my node1 and node3 back working (node2 and node3 exchanged IPs after reboot, to start to work this out today).

Do you have any further suggestions?

0 Likes 0 ·

What I think is strange, node2 was running and shortly visible in status message (this time, and last time with my first VM-attempt), before I was tidying up the IP-exchange disorder. And got interrupted by some strange update behaviour of the VM (CLIs were closed without warning, and weren't openable before it was finished). Log files are still not written.

0 Likes 0 ·